GitHub Advisoryadvisory · RubyGems
GHSA-438x-2p9v-g8h9 Camaleon CMS Insufficient Session Expiration vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2021-25970
- Ecosystem
- RubyGems
- Packages
- camaleon_cms
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-613
- Reviewed
- 2023-01-24
Affected packages
• RubyGems camaleon_cms: >= 0.1.7, < 2.6.0.1 → fixed in 2.6.0.1
Description
Camaleon CMS 0.1.7 through 2.6.0 doesn’t terminate the active session of the users, even after the admin changes the user’s password. A user that was already logged in, will still have access to the application even after the password was changed. Resolved in commit `77e31bc6cdde7c951fba104aebcd5ebb3f02b030` which is included in the `2.6.0.1` release.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2021-25970 Camaleon CMS 0.1.7 to 2.6.0 doesn’t terminate the active session of the users, even after the admin changes the user’s password. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-25970 advisory
- https://github.com/owen2345/camaleon-cms/commit/77e31bc6cdde7c951fba104aebcd5ebb3f02b030 web
- https://github.com/owen2345/camaleon-cms package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/camaleon_cms/CVE-2021-25970.yml web
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25970 web