GitHub Advisoryadvisory · Packagist
GHSA-43xg-87xw-jpv8 Several Zend Products Vulnerable to XXE and XEE attacks
MEDIUM
Official page ↗
- Aliases
- CVE-2014-2681
- Ecosystem
- Packagist
- Packages
- zendframework/zendframework1, zendframework/zendopenid, zendframework/zendrest, zendframework/zendservice-audioscrobbler, zendframework/zendservice-nirvanix, zendframework/zendservice-slideshare, zendframework/zendservice-technorati, zendframework/zendservice-windowsazure, zendframework/zendservice-amazon, zendframework/zendservice-api
- Severity
- Moderate
- Weaknesses
- CWE-611
- Reviewed
- 2023-09-25
Affected packages
• Packagist zendframework/zendframework1: < 1.12.4 → fixed in 1.12.4
• Packagist zendframework/zendopenid: < 2.0.2 → fixed in 2.0.2
• Packagist zendframework/zendrest: < 2.0.2 → fixed in 2.0.2
• Packagist zendframework/zendservice-audioscrobbler: < 2.0.2 → fixed in 2.0.2
• Packagist zendframework/zendservice-nirvanix: < 2.0.2 → fixed in 2.0.2
• Packagist zendframework/zendservice-slideshare: < 2.0.2 → fixed in 2.0.2
• Packagist zendframework/zendservice-technorati: < 2.0.2 → fixed in 2.0.2
• Packagist zendframework/zendservice-windowsazure: < 2.0.2 → fixed in 2.0.2
• Packagist zendframework/zendservice-amazon: < 2.0.3 → fixed in 2.0.3
• Packagist zendframework/zendservice-api: < 1.0.0 → fixed in 1.0.0
Description
Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0 allow remote attackers to read arbitrary files, send HTTP requests to intranet servers, and possibly cause a denial of service (CPU and memory consumption) via an XML External Entity (XXE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-5657.
Related
Alias · CVE (1)
- CVE-2014-2681 Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest,… vulnerability
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-2681 advisory
- https://web.archive.org/web/20150523055201/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2014:072/?name=MDVSA-2014:072 web
- https://web.archive.org/web/20210125095213/http://www.securityfocus.com/bid/66358 web
- http://advisories.mageia.org/MGASA-2014-0151.html web
- http://framework.zend.com/security/advisory/ZF2014-01 web
- http://seclists.org/oss-sec/2014/q2/0 web
- http://www.debian.org/security/2015/dsa-3265 web