GitHub Advisoryadvisory · PyPI, Maven

GHSA-43xg-8wmj-cw8h Apache Spark vulnerable to Log Injection

MEDIUM Published 2022-11-01 Modified 2025-12-18 Official page ↗
Aliases
CVE-2022-31777
Ecosystem
PyPI, Maven
Packages
pyspark, org.apache.spark:spark-core_2.9.3, org.apache.spark:spark-core_2.13, org.apache.spark:spark-core_2.12, org.apache.spark:spark-core_2.11, org.apache.spark:spark-core_2.10
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-74
Reviewed
2022-11-01

Affected packages

• PyPI pyspark: < 3.2.2 → fixed in 3.2.2 • PyPI pyspark: >= 3.3.0, < 3.3.1 → fixed in 3.3.1 • Maven org.apache.spark:spark-core_2.9.3: < 3.2.2 (no fix yet) • Maven org.apache.spark:spark-core_2.13: < 3.2.2 → fixed in 3.2.2 • Maven org.apache.spark:spark-core_2.13: >= 3.3.0, < 3.3.1 → fixed in 3.3.1 • Maven org.apache.spark:spark-core_2.12: < 3.2.2 → fixed in 3.2.2 • Maven org.apache.spark:spark-core_2.12: >= 3.3.0, < 3.3.1 → fixed in 3.3.1 • Maven org.apache.spark:spark-core_2.11: < 3.2.2 (no fix yet) • Maven org.apache.spark:spark-core_2.10: < 3.2.2 (no fix yet)

Description

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Related

Alias · CVE (1)

  • CVE-2022-31777 A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute… vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References