GitHub Advisoryadvisory · PyPI

GHSA-444r-2whx-3685 Sentry: Superusers can execute arbitrary commands by injecting malicious pickle-serialized objects through audit log entry data parameter

HIGH Published 2026-05-10 Modified 2026-06-09 Official page ↗
Aliases
CVE-2021-47935
Ecosystem
PyPI
Packages
sentry
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2026-06-09

Affected packages

• PyPI sentry: < 8.1.4 → fixed in 8.1.4 • PyPI sentry: >= 8.2.0, < 8.2.2 → fixed in 8.2.2

Description

Sentry 8.2.0 contains a remote code execution vulnerability that allows authenticated superusers to execute arbitrary commands by injecting malicious pickle-serialized objects through the audit log entry data parameter. Attackers can submit crafted POST requests to the admin audit log endpoint with base64-encoded compressed pickle payloads in the data field to achieve code execution with application privileges.

Related

Alias · CVE (1)

  • CVE-2021-47935 Sentry 8.2.0 contains a remote code execution vulnerability that allows authenticated superusers to execute arbitrary commands by injecting… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References