GitHub Advisoryadvisory · NuGet
GHSA-447r-wph3-92pm Microsoft Security Advisory CVE-2024-38095 | .NET Denial of Service Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-38095
- Ecosystem
- NuGet
- Packages
- Microsoft.NetCore.App.Runtime.linux-arm, Microsoft.NetCore.App.Runtime.linux-arm64, Microsoft.NetCore.App.Runtime.linux-musl-arm, Microsoft.NetCore.App.Runtime.linux-musl-arm64, Microsoft.NetCore.App.Runtime.linux-musl-x64, Microsoft.NetCore.App.Runtime.linux-x64, Microsoft.NetCore.App.Runtime.osx-arm64, Microsoft.NetCore.App.Runtime.osx-x64, Microsoft.NetCore.App.Runtime.win-arm, Microsoft.NetCore.App.Runtime.win-arm64, Microsoft.NetCore.App.Runtime.win-x64, Microsoft.NetCore.App.Runtime.win-x86, System.Formats.Asn1
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2024-07-09
Affected packages
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 6.0.0, < 6.0.32 → fixed in 6.0.32
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 8.0.0, < 8.0.7 → fixed in 8.0.7
• NuGet System.Formats.Asn1: >= 5.0.0-preview.7.20364.11, < 6.0.1 → fixed in 6.0.1
• NuGet System.Formats.Asn1: >= 7.0.0-preview.1.22076.8, < 8.0.1 → fixed in 8.0.1
Description
Microsoft Security Advisory CVE-2024-38095 | .NET Denial of Service Vulnerability
Executive summary
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0 and .NET 8.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.
A Vulnerability exists when System.Formats.Asn1 in .NET parses an X.509 certificate or collection of certificates, a malicious certificate can result in excessive CPU consumption on all platforms result in Denial of Service.
Announcement
Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/312
Mitigation factors
Microsoft has not identified any mitigating factors for this vulnerability.
Affected software
• Any .NET 6.0 application running on .NET 6.0.31 or earlier.
• Any .NET 8.0 application running on .NET 8.0.6 or earlier.
Affected Packages
The vulnerability affects any Microsoft .NET Core project if it uses any of affected packages versions listed below
.NET 6
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >=6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =6.0.0, =5.0.0-preview.7.20364.11 | 6.0.1
.NET 8
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >=8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =8.0.0, =7.0.0-preview.1.22076.8 | 8.0.1
Advisory FAQ
How do I know if I am affected?
If you have a runtime or SDK with a version listed, or an affected package listed in affected software or affected packages, you're exposed to the vulnerability.
How do I fix the issue?
• To fix the issue please install the latest version of .NET 8.0 or .NET 7.0 or .NET 6.0. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
• If you have .NET 6.0 or greater installed, you can list the versions you have installed by running the `dotnet --info` command. You will see output like the following;
```
.NET Core SDK (reflecting any global.json):
Version: 8.0.200
Commit: 8473146e7d
Runtime Environment:
OS Name: Windows
OS Version: 10.0.18363
OS Platform: Windows
RID: win10-x64
Base Path: C:\Program Files\dotnet\sdk\6.0.300\
Host (useful for support):
Version: 8.0.3
Commit: 8473146e7d
.NET Core SDKs installed:
8.0.200 [C:\Program Files\dotnet\sdk]
.NET Core runtimes installed:
Microsoft.AspAspNetCore.App 8.0.3 [C:\Program Files\dotnet\shared\Microsoft.AspAspNetCore.App]
Microsoft.AspNetCore.App 8.0.3 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
Microsoft.WindowsDesktop.App 8.0.3 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
To install additional .NET Core runtimes or SDKs:
https://aka.ms/dotnet-download
```
• If you're using .NET 8.0, you should download and install .NET 8.0.7 Runtime or .NET 8.0.107 SDK (for Visual Studio 2022 v17.8) from https://dotnet.microsoft.com/download/dotnet-core/8.0.
• If you're using .NET 6.0, you should download and install Runtime 6.0.32 or SDK 6.0.132 (for Visual Studio 2022 v17.4) from https://dotnet.microsoft.com/download/dotnet-core/6.0.
.NET 6.0 and .NET 8.0 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.
Once you have installed the updated runtime or SDK, restart your apps for the update to take effect.
Additionally, if you've deployed self-contained applications targeting any of the impacted versions, these applications are also vulnerable and must be recompiled and …
Related
Alias · CVE (1)
- CVE-2024-38095 .NET and Visual Studio Denial of Service Vulnerability vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness