GitHub Advisoryadvisory · Maven

GHSA-4487-x383-qpph Possible privilege escalation in org.springframework:spring-core

HIGH Published 2018-10-17 Modified 2024-03-08 Official page ↗
Aliases
CVE-2018-1272
Ecosystem
Maven
Packages
org.springframework:spring-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Reviewed
2020-06-16

Affected packages

• Maven org.springframework:spring-core: < 4.3.15 → fixed in 4.3.15 • Maven org.springframework:spring-core: >= 5.0.0, < 5.0.5 → fixed in 5.0.5

Description

Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.15 and older unsupported versions, provide client-side support for multipart requests. When Spring MVC or Spring WebFlux server application (server A) receives input from a remote client, and then uses that input to make a multipart request to another server (server B), it can be exposed to an attack, where an extra multipart is inserted in the content of the request from server A, causing server B to use the wrong value for a part it expects. This could to lead privilege escalation, for example, if the part content represents a username or user roles.

Related

Alias · CVE (1)

  • CVE-2018-1272 Spring Framework, versions 5.0 prior to 5.0.5 and versions 4.3 prior to 4.3.15 and older unsupported versions, provide client-side support… vulnerability

References