GitHub Advisoryadvisory · Packagist
GHSA-44v2-prcf-pc3m Joomla Framework Database Package Vulnerable to SQL Injection
MEDIUM
Official page ↗
- Aliases
- CVE-2025-25226
- Ecosystem
- Packagist
- Packages
- joomla/database
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
- Weaknesses
- CWE-89
- Reviewed
- 2025-04-09
Affected packages
• Packagist joomla/database: >= 3.0.0, < 3.4.0 → fixed in 3.4.0
• Packagist joomla/database: >= 1.0.0, < 2.2.0 → fixed in 2.2.0
Description
Improper handling of identifiers lead to a SQL injection vulnerability in the quoteNameStr method of the database package. Please note: the affected method is a protected method. It has no usages in the original packages in neither the 2.x nor 3.x branch and therefore the vulnerability in question can not be exploited when using the original database class. However, classes extending the affected class might be affected, if the vulnerable method is used.
Related
Alias · CVE (1)
- CVE-2025-25226 Improper handling of identifiers lead to a SQL injection vulnerability in the quoteNameStr method of the database package. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness