GitHub Advisoryadvisory · Packagist

GHSA-4542-p56h-8xww Cross-Site Scripting (XSS) vulnerabilities in Neos

HIGH Published 2024-06-05 Modified 2024-06-05 Official page ↗
Ecosystem
Packagist
Packages
typo3/neos
Severity
High
Reviewed
2024-06-05

Affected packages

• Packagist typo3/neos: >= 1.2.0, < 1.2.13 → fixed in 1.2.13 • Packagist typo3/neos: >= 2.0.0, < 2.0.4 → fixed in 2.0.4

Description

It has been discovered that Neos is vulnerable to several XSS attacks. Through these vulnerabilities, an attacker could tamper with page rendering, redirect victims to a fake login page, or capture user credentials (such as cookies). With the potential backdoor upload an attacker could gain access to the server itself, to an extent mainly limited by the server setup.

References