GitHub Advisoryadvisory · Packagist

GHSA-454r-4cjv-vc9h Moodle allows attackers to obtain manager privileges

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-5266
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: >= 2.7.0, < 2.7.10 → fixed in 2.7.10 • Packagist moodle/moodle: >= 2.8.0, < 2.8.8 → fixed in 2.8.8 • Packagist moodle/moodle: >= 2.9.0, < 2.9.2 → fixed in 2.9.2

Description

The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.

Related

Alias · CVE (1)

  • CVE-2015-5266 The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before… vulnerability

References