GitHub Advisoryadvisory · Maven

GHSA-455j-8hg5-8576 Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin

HIGH Published 2022-04-13 Modified 2022-12-02 Official page ↗
Aliases
CVE-2022-29039
Ecosystem
Maven
Packages
com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2022-12-02

Affected packages

• Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger: < 2.35.3 → fixed in 2.35.3

Description

Jenkins Gerrit Trigger Plugin 2.35.2 and earlier does not escape the name and description of parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of these vulnerabilities requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.

Related

Alias · CVE (1)

  • CVE-2022-29039 Jenkins Gerrit Trigger Plugin 2.35.2 and earlier does not escape the name and description of Base64 Encoded String parameters on views… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References