GitHub Advisoryadvisory · Go
GHSA-4578-6gjh-f2jm Mattermost allows an unauthorized Guest user access to Playbook
MEDIUM
Official page ↗
- Aliases
- CVE-2025-3228
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-06-20
Affected packages
• Go github.com/mattermost/mattermost-server: < 0.0.0-20250520060012-d0380305ef7a → fixed in 0.0.0-20250520060012-d0380305ef7a
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250520060012-d0380305ef7a → fixed in 8.0.0-20250520060012-d0380305ef7a
• Go github.com/mattermost/mattermost/server/v8: >= 10.5.0, < 10.5.6 → fixed in 10.5.6
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.16 → fixed in 9.11.16
• Go github.com/mattermost/mattermost/server/v8: >= 10.8.0, < 10.8.1 → fixed in 10.8.1
• Go github.com/mattermost/mattermost/server/v8: >= 10.7.0, < 10.7.3 → fixed in 10.7.3
• Go github.com/mattermost/mattermost/server/v8: >= 10.6.0, < 10.6.6 → fixed in 10.6.6
Description
Mattermost versions 10.5.x <= 10.5.5, 9.11.x <= 9.11.15, 10.8.x <= 10.8.0, 10.7.x <= 10.7.2, 10.6.x <= 10.6.5 fail to properly retrieve requestorInfo from playbooks handler for guest users which allows an attacker access to the playbook run.
Related
Alias · CVE (1)
- CVE-2025-3228 Mattermost versions 10.5.x <= 10.5.5, 9.11.x <= 9.11.15, 10.8.x <= 10.8.0, 10.7.x <= 10.7.2, 10.6.x <= 10.6.5 fail to properly retrieve… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness