GitHub Advisoryadvisory · npm
GHSA-457r-cqc8-9vj9 sweetalert2 v10.16.10 and above contains hidden functionality
LOW
Official page ↗
- Ecosystem
- npm
- Packages
- sweetalert2
- Severity
- Low
- Weaknesses
- CWE-912
- Reviewed
- 2022-11-23
Affected packages
• npm sweetalert2: >= 10.16.10, < 11.22.4 → fixed in 11.22.4
Description
`sweetalert2` versions 10.16.10 and up until 11.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 10.0.0 - 10.16.9.
Workaround
Use a version 10.0.0 - 10.16.9 of the package until the maintainer releases a fix.
Related
Weakness · CWE (1)
- CWE-912 Hidden Functionality weakness