GitHub Advisoryadvisory · PyPI

GHSA-45pg-36p6-83v9 Langchain SQL Injection vulnerability

LOW Published 2024-10-29 Modified 2024-11-12 Official page ↗
Aliases
CVE-2024-8309
Ecosystem
PyPI
Packages
langchain-community, langchain
Severity
Low
CVSS vector
CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-74, CWE-89
Reviewed
2024-10-29

Affected packages

• PyPI langchain-community: >= 0.2.0, < 0.2.19 → fixed in 0.2.19 • PyPI langchain: < 0.2.0 → fixed in 0.2.0

Description

A vulnerability in the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5 allows for SQL injection through prompt injection. This vulnerability can lead to unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

Related

Alias · CVE (1)

  • CVE-2024-8309 A vulnerability in the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5 allows for SQL injection through prompt injection. vulnerability

Weakness · CWE (2)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References