GitHub Advisoryadvisory · Maven
GHSA-45v7-65q8-x294 Stored XSS vulnerability in Jenkins Bitbucket Server Integration Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-28133
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:atlassian-bitbucket-server-integration
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-11-29
Affected packages
• Maven io.jenkins.plugins:atlassian-bitbucket-server-integration: >= 2.0.0, < 3.2.0 → fixed in 3.2.0
Description
Jenkins Bitbucket Server Integration Plugin 3.1.0 and earlier does not limit URL schemes for callback URLs on OAuth consumers, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create BitBucket Server consumers.
Related
Alias · CVE (1)
- CVE-2022-28133 Jenkins Bitbucket Server Integration Plugin 3.1.0 and earlier does not limit URL schemes for callback URLs on OAuth consumers, resulting in… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness