GitHub Advisoryadvisory · Packagist

GHSA-45vm-3j38-7p78 PrestaShop cross-site scripting via customer contact form in FO, through file upload

CRITICAL Published 2024-05-14 Modified 2024-05-14 Official page ↗
Aliases
CVE-2024-34716
Ecosystem
Packagist
Packages
prestashop/prestashop
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2024-05-14

Affected packages

• Packagist prestashop/prestashop: >= 8.1.0, < 8.1.6 → fixed in 8.1.6

Description

Impact Only PrestaShops with customer-thread feature flag enabled are impacted, starting from PrestaShop 8.1.0. The impact is substantial, when the customer thread feature flag is enabled, through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. Consequence: the script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. Patches This vulnerability is patched in 8.1.6. Workarounds As long as you have not upgraded to 8.1.6, a simple workaround is to disable the customer-thread feature-flag. Thank you to Ayoub AIT ELMOKHTAR, who discovered this vulnerability and share it with the PrestaShop team.

Related

Alias · CVE (1)

  • CVE-2024-34716 PrestaShop is an open source e-commerce web application. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References