GitHub Advisoryadvisory · RubyGems

GHSA-469h-mqg8-535r Decidim Cross-site Scripting vulnerability in the external link redirections

MEDIUM Published 2023-07-11 Modified 2023-07-20 Official page ↗
Aliases
CVE-2023-32693
Ecosystem
RubyGems
Packages
decidim, decidim-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-11

Affected packages

• RubyGems decidim: >= 0.25.0, < 0.26.7 → fixed in 0.26.7 • RubyGems decidim-core: >= 0.27.0, < 0.27.3 → fixed in 0.27.3 • RubyGems decidim-core: >= 0.25.0, < 0.26.7 → fixed in 0.26.7 • RubyGems decidim: >= 0.27.0, < 0.27.3 → fixed in 0.27.3

Description

Impact The external link feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. Patches The problem was patched in v0.27.3 and v0.26.7

Related

Alias · CVE (1)

  • CVE-2023-32693 Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References