GitHub Advisoryadvisory · Packagist

GHSA-46h7-vj7x-fxg2 Shopware has Improper Input Validation issue in newsletter subscription

MEDIUM Published 2023-01-20 Modified 2023-01-20 Official page ↗
Aliases
CVE-2023-22734
Ecosystem
Packagist
Packages
shopware/platform, shopware/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-20
Reviewed
2023-01-20

Affected packages

• Packagist shopware/platform: < 6.4.18.1 → fixed in 6.4.18.1 • Packagist shopware/core: < 6.4.18.1 → fixed in 6.4.18.1

Description

Impact The newsletter double opt-in validation was not checked properly, and it was possible to skip the complete double opt in process. Patches The problem has been fixed with 6.4.18.1 Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. Or disable the newsletter registration completely. References https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates

Related

Alias · CVE (1)

  • CVE-2023-22734 Shopware is an open source commerce platform based on Symfony Framework and Vue js. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References