GitHub Advisoryadvisory · npm

GHSA-479c-33wc-g2pg React Server Components have a Denial of Service Vulnerability

HIGH Published 2026-04-10 Modified 2026-04-10 Official page ↗
Aliases
CVE-2026-23869
Ecosystem
npm
Packages
react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-502
Reviewed
2026-04-10

Affected packages

• npm react-server-dom-parcel: >= 19.0.0, < 19.0.5 → fixed in 19.0.5 • npm react-server-dom-parcel: >= 19.1.0, < 19.1.6 → fixed in 19.1.6 • npm react-server-dom-parcel: >= 19.2.0, < 19.2.5 → fixed in 19.2.5 • npm react-server-dom-turbopack: >= 19.0.0, < 19.0.5 → fixed in 19.0.5 • npm react-server-dom-turbopack: >= 19.1.0, < 19.1.6 → fixed in 19.1.6 • npm react-server-dom-turbopack: >= 19.2.0, < 19.2.5 → fixed in 19.2.5 • npm react-server-dom-webpack: >= 19.0.0, < 19.0.5 → fixed in 19.0.5 • npm react-server-dom-webpack: >= 19.1.0, < 19.1.6 → fixed in 19.1.6 • npm react-server-dom-webpack: >= 19.2.0, < 19.2.5 → fixed in 19.2.5

Description

Impact A denial of service vulnerability exists in React Server Components, affecting the following packages: react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack versions 19.0.0, 19.1.0 and 19.2.0. The vulnerability is triggered by sending specially crafted HTTP requests to Server Function endpoints. The payload of the HTTP request causes excessive CPU usage for up to a minute ending in a thrown error that is catchable. We recommend updating immediately. The vulnerability exists in versions 19.0.0 through 19.0.4, 19.1.0 through 19.1.5, and 19.2.0 through 19.2.4 of: react-server-dom-webpack react-server-dom-parcel react-server-dom-turbopack Patches Fixes were back ported to versions 19.0.5, 19.1.6, and 19.2.5. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability. References See the blog post for more information and upgrade instructions.

Related

Alias · CVE (1)

  • CVE-2026-23869 A denial of service vulnerability exists in React Server Components, affecting the following packages: react-server-dom-parcel,… vulnerability

Weakness · CWE (2)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References