GitHub Advisoryadvisory · PyPI
GHSA-47h8-jmp3-9f28 pyrage vulnerable to malicious plugin names, recipients, or identities causing arbitrary binary execution
HIGH
Official page ↗
- Aliases
- CVE-2024-56327
- Ecosystem
- PyPI
- Packages
- pyrage
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1395, CWE-25, CWE-94
- Reviewed
- 2024-12-19
Affected packages
• PyPI pyrage: >= 1.2.0, < 1.2.3 → fixed in 1.2.3
Description
`pyrage` uses the Rust `age` crate for its underlying operations, and `age` is vulnerable to GHSA-4fg7-vxc8-qx5w.
All details of GHSA-4fg7-vxc8-qx5w are relevant to `pyrage` for the versions specified in this advisory. See GHSA-4fg7-vxc8-qx5w for full details.
Versions of `pyrage` before 1.2.0 lack plugin support and are therefore not affected.
An equivalent issue was fixed in the reference Go implementation of age, see advisory GHSA-32gq-x56h-299c.
Thanks to ⬡-49016 for reporting this issue.
Related
Alias · CVE (1)
- CVE-2024-56327 pyrage is a set of Python bindings for the rage file encryption library (age in Rust). vulnerability
References
- https://github.com/FiloSottile/age/security/advisories/GHSA-32gq-x56h-299c web
- https://github.com/str4d/rage/security/advisories/GHSA-4fg7-vxc8-qx5w web
- https://github.com/woodruffw/pyrage/security/advisories/GHSA-47h8-jmp3-9f28 web
- https://nvd.nist.gov/vuln/detail/CVE-2024-56327 advisory
- https://github.com/advisories/GHSA-4fg7-vxc8-qx5w advisory
- https://github.com/woodruffw/pyrage package