GitHub Advisoryadvisory · NuGet

GHSA-485p-mrj5-8w2v .NET Denial of Service Vulnerability

HIGH Published 2022-10-21 Modified 2025-01-02 Official page ↗
Aliases
CVE-2022-23267
Ecosystem
NuGet
Packages
Microsoft.AspNetCore.App.Runtime.linux-arm, Microsoft.AspNetCore.App.Runtime.linux-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-arm64, Microsoft.AspNetCore.App.Runtime.linux-musl-x64, Microsoft.AspNetCore.App.Runtime.linux-x64, Microsoft.AspNetCore.App.Runtime.osx-x64, Microsoft.AspNetCore.App.Runtime.win-arm, Microsoft.AspNetCore.App.Runtime.win-arm64, Microsoft.AspNetCore.App.Runtime.win-x64, Microsoft.AspNetCore.App.Runtime.win-x86, Microsoft.AspNetCore.App.Runtime.linux-musl-arm, Microsoft.AspNetCore.App.Runtime.osx-arm64
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2022-10-21

Affected packages

• NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 3.0.0, < 3.1.25 → fixed in 3.1.25 • NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 5.0.0, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 5.0.1, < 5.0.17 → fixed in 5.0.17 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.linux-arm64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-arm64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.linux-musl-x64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.linux-x64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.osx-arm64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.osx-x64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.win-arm64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.win-x64: >= 6.0.0, < 6.0.5 → fixed in 6.0.5 • NuGet Microsoft.AspNetCore.App.Runtime.win-x86: >= 6.0.0, < 6.0.5 → fixed in 6.0.5

Description

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0 and .NET Core 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET 5.0 and .NET Core 3.1 where a malicious client can cause a Denial of Service via excess memory allocations through HttpClient. Affected software • Any .NET 6.0 application running on .NET 6.0.4 or earlier. • Any .NET 5.0 application running .NET 5.0.16 or earlier. • Any .NET Core 3.1 applicaiton running on .NET Core 3.1.24 or earlier. Patches • If you're using .NET Core 6.0, you should download and install Runtime 6.0.5 or SDK 6.0.105 (for Visual Studio 2022 v17.0) or SDK 6.0.203 (for Visual Studio 2022 v17.1) from https://dotnet.microsoft.com/download/dotnet-core/6.0. • If you're using .NET 5.0, you should download and install Runtime 5.0.17 or SDK 5.0.214 (for Visual Studio 2019 v16.9) or SDK 5.0.408 (for Visual Studio 2011 v16.11) from https://dotnet.microsoft.com/download/dotnet-core/5.0. • If you're using .NET Core 3.1, you should download and install Runtime 3.1.25 or SDK 3.1.419 (for Visual Studio 2019 v16.9 or Visual Studio 2011 16.11 or Visual Studio 2022 17.0 or Visual Studio 2022 17.1 ) from https://dotnet.microsoft.com/download/dotnet-core/3.1. .NET 6.0, .NET 5.0 and .NET Core 3.1 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates. Other Details Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/221 An Issue for this can be found at https://github.com/dotnet/runtime/issues/69149 MSRC details for this can be found at https://msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2022-23267

Related

Alias · CVE (1)

  • CVE-2022-23267 .NET and Visual Studio Denial of Service Vulnerability vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References