GitHub Advisoryadvisory · PyPI

GHSA-4894-5vqc-6r2r Django cross-site scripting (XSS) vulnerability in the AdminURLFieldWidget widget

MEDIUM Published 2022-05-17 Modified 2024-09-18 Official page ↗
Aliases
CVE-2013-4249
Ecosystem
PyPI
Packages
django
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-08-17

Affected packages

• PyPI django: >= 1.5, < 1.5.2 → fixed in 1.5.2

Description

Cross-site scripting (XSS) vulnerability in the AdminURLFieldWidget widget in contrib/admin/widgets.py in Django 1.5.x before 1.5.2 and 1.6.x before 1.6 beta 2 allows remote attackers to inject arbitrary web script or HTML via a URLField.

Related

Alias · CVE (1)

  • CVE-2013-4249 Cross-site scripting (XSS) vulnerability in the AdminURLFieldWidget widget in contrib/admin/widgets.py in Django 1.5.x before 1.5.2 and… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References