GitHub Advisoryadvisory · Packagist
GHSA-48p3-xfvw-g59c Incorrect Access Control in ImpressCMS
MEDIUM
Official page ↗
- Aliases
- CVE-2021-26598
- Ecosystem
- Packagist
- Packages
- impresscms/impresscms
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2022-03-30
Affected packages
• Packagist impresscms/impresscms: < 1.4.3 → fixed in 1.4.3
Description
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
Related
Alias · CVE (1)
- CVE-2021-26598 ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by… vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-26598 advisory
- https://github.com/ImpressCMS/impresscms/pull/967 web
- https://hackerone.com/reports/1081137 web
- https://github.com/ImpressCMS/impresscms package
- https://github.com/ImpressCMS/impresscms/releases/tag/v1.4.3 web
- https://packetstormsecurity.com/files/166403/ImpressCMS-1.4.2-Incorrect-Access-Control.html web
- http://karmainsecurity.com/KIS-2022-03 web
- http://seclists.org/fulldisclosure/2022/Mar/45 web