GitHub Advisoryadvisory · Maven
GHSA-48pq-x3vw-4pqf Jenkins vSphere Plugin incorrect authorization vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000152
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:vsphere-cloud
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-863
- Reviewed
- 2022-12-07
Affected packages
• Maven org.jenkins-ci.plugins:vsphere-cloud: < 2.17 → fixed in 2.17
Description
An improper authorization vulnerability exists in Jenkins vSphere Plugin 2.16 and older in Clone.java, CloudSelectorParameter.java, ConvertToTemplate.java, ConvertToVm.java, Delete.java, DeleteSnapshot.java, Deploy.java, ExposeGuestInfo.java, FolderVSphereCloudProperty.java, PowerOff.java, PowerOn.java, Reconfigure.java, Rename.java, RenameSnapshot.java, RevertToSnapshot.java, SuspendVm.java, TakeSnapshot.java, VSphereBuildStepContainer.java, vSphereCloudProvisionedSlave.java, vSphereCloudSlave.java, vSphereCloudSlaveTemplate.java, VSphereConnectionConfig.java, vSphereStep.java that allows attackers to perform form validation related actions, including sending numerous requests to the configured vSphere server, potentially resulting in denial of service, or send credentials stored in Jenkins with known ID to an attacker-specified server ("test connection"). As of version 2.17, these form validation methods require POST requests and appropriate user permissions.
Related
Alias · CVE (1)
- CVE-2018-1000152 An improper authorization vulnerability exists in Jenkins vSphere Plugin 2.16 and older in Clone.java, CloudSelectorParameter.java,… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness