GitHub Advisoryadvisory · RubyGems
GHSA-48wp-p9qv-4j64 Commonmarker vulnerable to to several quadratic complexity bugs that may lead to denial of service
MEDIUM
Official page ↗
- Ecosystem
- RubyGems
- Packages
- commonmarker
- Severity
- Moderate
- Reviewed
- 2023-04-11
Affected packages
• RubyGems commonmarker: < 0.23.9 → fixed in 0.23.9
Description
Impact
Several quadratic complexity bugs in commonmarker's underlying `cmark-gfm` library may lead to unbounded resource exhaustion and subsequent denial of service.
The following vulnerabilities were addressed:
• CVE-2023-24824
• CVE-2023-26485
For more information, consult the release notes for version `0.23.0.gfm.10` and `0.23.0.gfm.11`.
Mitigation
Users are advised to upgrade to commonmarker version `0.23.9`.
References
- https://github.com/github/cmark-gfm/security/advisories/GHSA-66g8-4hjf-77xh web
- https://github.com/github/cmark-gfm/security/advisories/GHSA-r8vr-c48j-fcc5 web
- https://github.com/gjtorikian/commonmarker/security/advisories/GHSA-48wp-p9qv-4j64 web
- https://github.com/gjtorikian/commonmarker/pull/236 web
- https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.10 web
- https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.11 web
- https://github.com/gjtorikian/commonmarker package
- https://github.com/gjtorikian/commonmarker/releases/tag/v0.23.9 web