GitHub Advisoryadvisory · RubyGems

GHSA-4936-rj25-6wm6 nori contains Improper Input Validation

HIGH Published 2017-10-24 Modified 2023-01-20 Official page ↗
Aliases
CVE-2013-0285
Ecosystem
RubyGems
Packages
nori
Severity
High
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems nori: >= 2.0.0, < 2.0.2 → fixed in 2.0.2 • RubyGems nori: >= 1.1.0, < 1.1.4 → fixed in 1.1.4 • RubyGems nori: >= 1.0.0, < 1.0.3 → fixed in 1.0.3

Description

The nori gem 2.0.x before 2.0.2, 1.1.x before 1.1.4, and 1.0.x before 1.0.3 for Ruby does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.

Related

Alias · CVE (1)

  • CVE-2013-0285 The nori gem 2.0.x before 2.0.2, 1.1.x before 1.1.4, and 1.0.x before 1.0.3 for Ruby does not properly restrict casts of string values,… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References