GitHub Advisoryadvisory · Maven

GHSA-493p-pfq6-5258 json-smart Uncontrolled Recursion vulnerability

HIGH Published 2023-03-23 Modified 2026-08-04 Official page ↗
Aliases
CVE-2023-1370
Ecosystem
Maven
Packages
net.minidev:json-smart
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-674
Reviewed
2023-03-23

Affected packages

• Maven net.minidev:json-smart: < 2.4.9 → fixed in 2.4.9

Description

Impact Affected versions of net.minidev:json-smart are vulnerable to Denial of Service (DoS) due to a StackOverflowError when parsing a deeply nested JSON array or object. When reaching a ‘[‘ or ‘{‘ character in the JSON input, the code parses an array or an object respectively. It was discovered that the 3PP does not have any limit to the nesting of such arrays or objects. Since the parsing of nested arrays and objects is done recursively, nesting too many of them can cause stack exhaustion (stack overflow) and crash the software. Patches This vulnerability was fixed in json-smart version 2.4.9, but the maintainer recommends upgrading to 2.4.10, due to a remaining bug. Workarounds N/A References • https://www.cve.org/CVERecord?id=CVE-2023-1370 • https://nvd.nist.gov/vuln/detail/CVE-2023-1370 • https://security.snyk.io/vuln/SNYK-JAVA-NETMINIDEV-3369748

Related

Alias · CVE (1)

  • CVE-2023-1370 [Json-smart](https://netplex.github.io/json-smart/) is a performance focused, JSON processor lib. vulnerability

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References