GitHub Advisoryadvisory · Go
GHSA-4993-m7g5-r9hh etcd has no minimum password length
MEDIUM
Official page ↗
- Aliases
- CVE-2020-15115
- Ecosystem
- Go
- Packages
- go.etcd.io/etcd/client/v3
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- Weaknesses
- CWE-521
- Reviewed
- 2022-10-06
Affected packages
• Go go.etcd.io/etcd/client/v3: >= 3.4.0, < 3.4.10 → fixed in 3.4.10
• Go go.etcd.io/etcd/client/v3: < 3.3.23 → fixed in 3.3.23
Description
Vulnerability type
Access Control
Workarounds
The etcdctl and etcd API do not enforce a specific password length during user creation or user password update operations. It is the responsibility of the administrator to enforce these requirements.
Detail
etcd does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users’ passwords with little computational effort.
References
Find out more on this vulnerability in the security audit report
For more information
If you have any questions or comments about this advisory:
• Contact the etcd security committee
Related
Alias · CVE (1)
- CVE-2020-15115 etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as… vulnerability
Weakness · CWE (1)
- CWE-521 Weak Password Requirements weakness