GitHub Advisoryadvisory · PyPI
GHSA-49cw-434h-qc57 Mercurial vulnerable to arbitrary code execution when converting Git repos
HIGH
Official page ↗
- Aliases
- CVE-2016-3105
- Ecosystem
- PyPI
- Packages
- mercurial
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284
- Reviewed
- 2024-05-01
Affected packages
• PyPI mercurial: < 3.8 → fixed in 3.8
Description
The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.
Related
Alias · CVE (1)
- CVE-2016-3105 The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-3105 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2016-28.yaml web
- https://security.gentoo.org/glsa/201612-19 web
- https://selenic.com/hg/rev/a56296f55a5e web
- https://web.archive.org/web/20200228012056/http://www.securityfocus.com/bid/90536 web
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.8_.2F_3.8.1_.282016-5-1.29 web
- http://lists.opensuse.org/opensuse-updates/2016-05/msg00082.html web
- http://www.debian.org/security/2016/dsa-3570 web
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.533255 web