GitHub Advisoryadvisory · PyPI

GHSA-49f7-whx5-4256 Cognee allows non-superusers to overwrite global LLM configuration

CRITICAL Published 2026-07-07 Modified 2026-09-03 Official page ↗
Aliases
CVE-2026-58473
Ecosystem
PyPI
Packages
cognee
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-306
Reviewed
2026-09-03

Affected packages

• PyPI cognee: < 1.5.0 → fixed in 1.5.0

Description

Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.

Related

Alias · CVE (1)

  • CVE-2026-58473 Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM… vulnerability

Weakness · CWE (1)

  • CWE-306 Missing Authentication for Critical Functionality weakness

References