GitHub Advisoryadvisory · NuGet
GHSA-4c29-gfrp-g6x9 CefSharp affected by libvpx's heap buffer overflow in vp8 encoding
HIGH
Official page ↗
- Ecosystem
- NuGet
- Packages
- CefSharp.Common, CefSharp.Common.NETCore
- Severity
- High
- Reviewed
- 2023-10-05
Affected packages
• NuGet CefSharp.Common: < 117.2.20 → fixed in 117.2.20
• NuGet CefSharp.Common.NETCore: < 117.2.20 → fixed in 117.2.20
Description
Google is aware that an exploit for CVE-2023-5217 exists in the wild.
Description
Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
References
• https://www.cve.org/CVERecord?id=CVE-2023-5217
• https://nvd.nist.gov/vuln/detail/CVE-2023-5217