GitHub Advisoryadvisory · Maven

GHSA-4c32-xmgj-2g98 High severity vulnerability that affects org.apache.pdfbox:pdfbox

HIGH Published 2018-10-17 Modified 2021-09-01 Official page ↗
Aliases
CVE-2016-2175
Ecosystem
Maven
Packages
org.apache.pdfbox:pdfbox
Severity
High
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-611
Reviewed
2020-06-16

Affected packages

• Maven org.apache.pdfbox:pdfbox: < 1.8.12 → fixed in 1.8.12 • Maven org.apache.pdfbox:pdfbox: >= 2.0.0, < 2.0.1 → fixed in 2.0.1

Description

Apache PDFBox before 1.8.12 and 2.x before 2.0.1 does not properly initialize the XML parsers, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted PDF.

Related

Alias · CVE (1)

  • CVE-2016-2175 Apache PDFBox before 1.8.12 and 2.x before 2.0.1 does not properly initialize the XML parsers, which allows context-dependent attackers to… vulnerability

Weakness · CWE (1)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References