GitHub Advisoryadvisory · Maven
GHSA-4c3q-r84r-q6pp Jenkins mabl Plugin vulnerable to exposure of system-scooped credentials
MEDIUM
Official page ↗
- Aliases
- CVE-2023-37951
- Ecosystem
- Maven
- Packages
- com.mabl.integration.jenkins:mabl-integration
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2023-07-12
Affected packages
• Maven com.mabl.integration.jenkins:mabl-integration: < 0.0.47 → fixed in 0.0.47
Description
Jenkins mabl Plugin 0.0.46 and earlier does not set the appropriate context for credentials lookup, allowing the use of System-scoped credentials otherwise reserved for the global configuration.
This allows attackers with Item/Configure permission to access and capture credentials they are not entitled to.
mabl Plugin 0.0.47 defines the appropriate context for credentials lookup.
Related
Alias · CVE (1)
- CVE-2023-37951 Jenkins mabl Plugin 0.0.46 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness