GitHub Advisoryadvisory · PyPI
GHSA-4c42-4rxm-x6qf Django Denial of Service Vulnerability in the authentication framework
HIGH
Official page ↗
- Aliases
- CVE-2013-1443
- Ecosystem
- PyPI
- Packages
- Django
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2023-08-17
Affected packages
• PyPI Django: >= 1.4, < 1.4.8 → fixed in 1.4.8
• PyPI Django: >= 1.5, < 1.5.4 → fixed in 1.5.4
Description
The authentication framework (django.contrib.auth) in Django 1.4.x before 1.4.8, 1.5.x before 1.5.4, and 1.6.x before 1.6 beta 4 allows remote attackers to cause a denial of service (CPU consumption) via a long password which is then hashed.
Related
Alias · CVE (1)
- CVE-2013-1443 The authentication framework (django.contrib.auth) in Django 1.4.x before 1.4.8, 1.5.x before 1.5.4, and 1.6.x before 1.6 beta 4 allows… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2013-1443 advisory
- https://github.com/django/django/commit/22b74fa09d7ccbc8c52270d648a0da7f3f0fa2bc web
- https://github.com/django/django/commit/3f3d887a6844ec2db743fee64c9e53e04d39a368 web
- https://github.com/django/django package
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2013-18.yaml web
- https://www.djangoproject.com/weblog/2013/sep/15/security web
- http://lists.opensuse.org/opensuse-updates/2013-10/msg00015.html web
- http://lists.opensuse.org/opensuse-updates/2013-11/msg00035.html web
- http://python.6.x6.nabble.com/Set-a-reasonable-upper-bound-on-password-length-td5032218.html web
- http://www.debian.org/security/2013/dsa-2758 web