GitHub Advisoryadvisory · Packagist

GHSA-4c5g-w3gf-rf4f Moodle allows attackers to obtain username and course information

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-3546
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.4.11 → fixed in 2.4.11 • Packagist moodle/moodle: >= 2.5.0, < 2.5.7 → fixed in 2.5.7 • Packagist moodle/moodle: >= 2.6.0, < 2.6.4 → fixed in 2.6.4 • Packagist moodle/moodle: >= 2.7.0, < 2.7.1 → fixed in 2.7.1

Description

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 does not enforce certain capability requirements in (1) notes/index.php and (2) user/edit.php, which allows remote attackers to obtain potentially sensitive username and course information via a modified URL.

Related

Alias · CVE (1)

  • CVE-2014-3546 Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 does not enforce certain… vulnerability

References