GitHub Advisoryadvisory · npm
GHSA-4c7m-wxvm-r7gc Improper parsing of octal bytes in netmask
CRITICAL
Official page ↗
- Aliases
- CVE-2021-28918
- Ecosystem
- npm
- Packages
- netmask
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2021-04-13
Affected packages
• npm netmask: < 1.1.0 → fixed in 1.1.0
Description
Improper input validation of octal strings in netmask npm package v1.0.6 and below allows unauthenticated remote attackers to perform indeterminate SSRF, RFI, and LFI attacks on many of the dependent packages. A remote unauthenticated attacker can bypass packages relying on netmask to filter IPs and reach critical VPN or LAN hosts.
:exclamation: NOTE: The fix for this issue was incomplete. A subsequent fix was made in version `2.0.1` which was assigned CVE-2021-29418 / GHSA-pch5-whg9-qr2r. For complete protection from this vulnerability an upgrade to version 2.0.1 or later is recommended.
Related
Alias · CVE (1)
- CVE-2021-28918 Improper input validation of octal strings in netmask npm package v1.0.6 and below allows unauthenticated remote attackers to perform… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-28918 advisory
- https://github.com/advisories/GHSA-pch5-whg9-qr2r advisory
- https://github.com/rs/node-netmask web
- https://github.com/rs/node-netmask/blob/98294cb20695f2c6c36219a4fbcd4744fb8d0682/CHANGELOG.md#v110-mar-18-2021 web
- https://github.com/sickcodes/security/blob/master/advisories/SICK-2021-011.md web
- https://rootdaemon.com/2021/03/29/vulnerability-in-netmask-npm-package-affects-280000-projects web
- https://security.netapp.com/advisory/ntap-20210528-0010 web
- https://www.bleepingcomputer.com/news/security/critical-netmask-networking-bug-impacts-thousands-of-applications web
- https://www.npmjs.com/package/netmask web