GitHub Advisoryadvisory · Maven
GHSA-4f6x-g5vh-8jm5 Stored XSS vulnerability in Jenkins Active Choices Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21616
- Ecosystem
- Maven
- Packages
- org.biouno:uno-choice
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-13
Affected packages
• Maven org.biouno:uno-choice: < 2.5.3 → fixed in 2.5.3
Description
Jenkins Active Choices Plugin 2.5.2 and earlier does not escape reference parameter values.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.
Jenkins Active Choices Plugin 2.5.3 escapes reference parameter values.
Related
Alias · CVE (1)
- CVE-2021-21616 Jenkins Active Choices Plugin 2.5.2 and earlier does not escape reference parameter values, resulting in a stored cross-site scripting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21616 advisory
- https://github.com/jenkinsci/active-choices-plugin/commit/d0b768c18bafd812b52fe579def8b14e26033ec9 web
- https://github.com/jenkinsci/active-choices-plugin package
- https://www.jenkins.io/security/advisory/2021-02-24/#SECURITY-2192 web
- http://www.openwall.com/lists/oss-security/2021/02/24/3 web