GitHub Advisoryadvisory · npm
GHSA-4f8g-77mw-3rxc OpenClaw: Gateway plugin HTTP `auth: gateway` widens identity-bearing `operator.read` requests into runtime `operator.write`
LOW
Official page ↗
- Aliases
- CVE-2026-42429
- Ecosystem
- npm
- Packages
- openclaw
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- Weaknesses
- CWE-269, CWE-863
- Reviewed
- 2026-04-09
Affected packages
• npm openclaw: < 2026.4.8 → fixed in 2026.4.8
Description
Impact
Gateway plugin HTTP `auth: gateway` widens identity-bearing `operator.read` requests into runtime `operator.write`.
Plugin HTTP routes using gateway auth could receive runtime write scopes even when the upstream trusted-proxy request only declared read.
OpenClaw is a user-controlled local assistant. This advisory is scoped to the OpenClaw trust model and does not assume a multi-tenant service boundary.
Affected Packages / Versions
• Package: `openclaw` (npm)
• Affected versions: `2026.1.29`
• Patched versions: `2026.4.8`
Fix
The issue was fixed on `main` and is available in the patched npm version listed above. The verified fixed tree is commit `d7c3210cd6f5fdfdc1beff4c9541673e814354d5`.
Verification
The fix was re-checked against `main` before publication, including targeted regression tests for the affected security boundary.
Credits
Thanks @smaeljaish771 for reporting.
Related
Alias · CVE (1)
- CVE-2026-42429 OpenClaw before 2026.4.8 contains a privilege escalation vulnerability in the gateway plugin HTTP authentication mechanism that escalates… vulnerability
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-4f8g-77mw-3rxc web
- https://nvd.nist.gov/vuln/detail/CVE-2026-42429 advisory
- https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5 web
- https://github.com/openclaw/openclaw package
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-gateway-plugin-http-authentication web