GitHub Advisoryadvisory · Packagist

GHSA-4f8q-mwgc-3mwc Drupal OAuth2 Server Missing Authorization vulnerability

HIGH Published 2025-04-01 Modified 2025-04-29 Official page ↗
Aliases
CVE-2025-31691
Ecosystem
Packagist
Packages
drupal/oauth2_server
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-862
Reviewed
2025-04-02

Affected packages

• Packagist drupal/oauth2_server: < 2.1.0 → fixed in 2.1.0

Description

Missing Authorization vulnerability in Drupal OAuth2 Server allows Forceful Browsing. This issue affects OAuth2 Server: from 0.0.0 before 2.1.0.

Related

Alias · CVE (1)

  • CVE-2025-31691 Missing Authorization vulnerability in Drupal OAuth2 Server allows Forceful Browsing.This issue affects OAuth2 Server: from 0.0.0 before… vulnerability

Weakness · CWE (1)

  • CWE-862 Missing Authorization weakness

References