GitHub Advisoryadvisory · Go
GHSA-4fwj-8595-wp25 Mattermost has Insufficiently Protected Credentials
LOW
Official page ↗
- Aliases
- CVE-2025-6227
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2025-07-21
Affected packages
• Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.8 → fixed in 10.5.8
• Go github.com/mattermost/mattermost-server: >= 9.11.0, < 9.11.17 → fixed in 9.11.17
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250612074655-8f8612c63783 → fixed in 8.0.0-20250612074655-8f8612c63783
Description
Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.
Related
Alias · CVE (1)
- CVE-2025-6227 Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness