GitHub Advisoryadvisory · Packagist
GHSA-4g27-q2w9-m8m8 Magento affected by remote code execution vulnerability in the CMS page scheduled update feature
CRITICAL
Official page ↗
- Aliases
- CVE-2021-36021
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2025-11-06
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1
• Packagist magento/community-edition: 2.3.7 (no fix yet)
• Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2
• Packagist magento/community-edition: 2.4.2 (no fix yet)
Description
Magento versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an Improper input validation vulnerability within the CMS page scheduled update feature. An authenticated attacker with administrative privilege could leverage this vulnerability to achieve remote code execution on the system.
Related
Alias · CVE (1)
- CVE-2021-36021 Magento versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an Improper input validation… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness