GitHub Advisoryadvisory · Packagist
GHSA-4gjj-r7w8-42cq Jerome Gamez Firebase Admin SDK for PHP Incorrect Access Control vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2018-1000025
- Ecosystem
- Packagist
- Packages
- kreait/firebase-php
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-732
- Reviewed
- 2024-04-24
Affected packages
• Packagist kreait/firebase-php: >= 3.2.0, < 3.8.1 → fixed in 3.8.1
Description
Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in `src/Firebase/Auth/IdTokenVerifier.php` does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.
Related
Alias · CVE (1)
- CVE-2018-1000025 Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in… vulnerability
Weakness · CWE (1)
- CWE-732 Incorrect Permission Assignment for Critical Resource weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000025 advisory
- https://github.com/kreait/firebase-php/pull/151 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/kreait/firebase-php/CVE-2018-1000025.yaml web
- https://github.com/kreait/firebase-php package
- https://github.com/kreait/firebase-php/releases/tag/3.8.1 web