GitHub Advisoryadvisory · Packagist

GHSA-4gmg-gwjh-3mmr phpMyAdmin Cryptographic Vulnerability

HIGH Published 2022-05-17 Modified 2023-11-07 Official page ↗
Aliases
CVE-2016-1927
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Reviewed
2023-07-31

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.0.0, < 4.0.10.13 → fixed in 4.0.10.13 • Packagist phpmyadmin/phpmyadmin: >= 4.4.0, < 4.4.15.3 → fixed in 4.4.15.3 • Packagist phpmyadmin/phpmyadmin: >= 4.5.0, < 4.5.4 → fixed in 4.5.4

Description

The `suggestPassword` function in `js/functions.js` in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 relies on the `Math.random` JavaScript function, which makes it easier for remote attackers to guess passwords via a brute-force approach.

Related

Alias · CVE (1)

  • CVE-2016-1927 The suggestPassword function in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 relies… vulnerability

References