GitHub Advisoryadvisory · Packagist

GHSA-4gpr-p634-922x Cross site scripting via input unit widget

MEDIUM Published 2023-07-25 Modified 2025-04-17 Official page ↗
Aliases
CVE-2023-36806
Ecosystem
Packagist
Packages
contao/core-bundle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
Weaknesses
CWE-79
Reviewed
2023-07-25

Affected packages

• Packagist contao/core-bundle: >= 4.0.0, < 4.9.42 → fixed in 4.9.42 • Packagist contao/core-bundle: >= 4.10.0, < 4.13.28 → fixed in 4.13.28 • Packagist contao/core-bundle: >= 5.0.0, < 5.1.10 → fixed in 5.1.10

Description

Impact Authenticated users can inject malicious code in widgets with units, which is then executed both in the element preview (back end) and on the website (front end). Patches Update to Contao 4.9.42, 4.13.28 or 5.1.10. Workarounds Disable login for all untrusted back end users. References https://contao.org/en/security-advisories/cross-site-scripting-in-widgets-with-units For more information If you have any questions or comments about this advisory, open an issue in contao/contao. Credits Thanks to Christian Pöschl and Fabian Brenner from usd AG for reporting this vulnerability.

Related

Alias · CVE (1)

  • CVE-2023-36806 Contao is an open source content management system. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References