GitHub Advisoryadvisory · Packagist
GHSA-4gq2-x5w4-7hp8 Moodle has insufficient capability checks
LOW
Official page ↗
- Aliases
- CVE-2024-43435
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-754
- Reviewed
- 2024-11-12
Affected packages
• Packagist moodle/moodle: >= 4.4.0, < 4.4.2 → fixed in 4.4.2
• Packagist moodle/moodle: >= 4.3.0, < 4.3.6 → fixed in 4.3.6
• Packagist moodle/moodle: >= 4.2.0, < 4.2.9 → fixed in 4.2.9
• Packagist moodle/moodle: < 4.1.12 → fixed in 4.1.12
Description
A flaw was found in moodle. Insufficient capability checks make it possible for users with access to restore glossaries in courses to restore them into the global site glossary.
Related
Alias · CVE (1)
- CVE-2024-43435 A flaw was found in moodle. vulnerability
Weakness · CWE (1)
- CWE-754 Improper Check for Unusual or Exceptional Conditions weakness