GitHub Advisoryadvisory · PyPI

GHSA-4h97-wpxp-3757 LangGraph's SQLite store implementation has a SQL Injection Vulnerability

HIGH Published 2025-10-26 Modified 2025-10-27 Official page ↗
Aliases
CVE-2025-8709
Ecosystem
PyPI
Packages
langgraph-checkpoint-sqlite
Severity
High
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Weaknesses
CWE-89
Reviewed
2025-10-27

Affected packages

• PyPI langgraph-checkpoint-sqlite: < 2.0.11 → fixed in 2.0.11

Description

A SQL injection vulnerability exists in the langchain-ai/langgraph repository, specifically in the LangGraph's SQLite store implementation. The affected version is langgraph-checkpoint-sqlite 2.0.10. The vulnerability arises from improper handling of filter operators ($eq, $ne, $gt, $lt, $gte, $lte) where direct string concatenation is used without proper parameterization. This allows attackers to inject arbitrary SQL, leading to unauthorized access to all documents, data exfiltration of sensitive fields such as passwords and API keys, and a complete bypass of application-level security filters.

Related

Alias · CVE (1)

  • CVE-2025-8709 A SQL injection vulnerability exists in the langchain-ai/langchain repository, specifically in the LangGraph's SQLite store implementation. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References