GitHub Advisoryadvisory · Packagist
GHSA-4h9c-v5vg-5m6m Access to restricted PHP code by dynamic static class access in smarty
HIGH
Official page ↗
- Aliases
- CVE-2021-21408
- Ecosystem
- Packagist
- Packages
- smarty/smarty
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-01-10
Affected packages
• Packagist smarty/smarty: < 3.1.43 → fixed in 3.1.43
• Packagist smarty/smarty: >= 4.0.0, < 4.0.3 → fixed in 4.0.3
Description
Impact
Template authors could run restricted static php methods.
Patches
Please upgrade to 3.1.40 or higher.
References
See the documentation on Smarty security features on the static_classes access filter.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
Related
Alias · CVE (1)
- CVE-2021-21408 Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/smarty-php/smarty/security/advisories/GHSA-4h9c-v5vg-5m6m web
- https://nvd.nist.gov/vuln/detail/CVE-2021-21408 advisory
- https://github.com/smarty-php/smarty/commit/19ae410bf56007a5ef24441cdc6414619cfaf664 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/smarty/smarty/CVE-2021-21408.yaml web
- https://github.com/smarty-php/smarty package
- https://github.com/smarty-php/smarty/releases/tag/v3.1.43 web
- https://github.com/smarty-php/smarty/releases/tag/v4.0.3 web
- https://lists.debian.org/debian-lts-announce/2022/05/msg00005.html web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/BRAJVDRGCIY5UZ2PQHKDTT7RMKG6WJQQ web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/L777JIBIWJV34HS7LXPIDWASG7TT4LNI web
- https://security.gentoo.org/glsa/202209-09 web
- https://www.debian.org/security/2022/dsa-5151 web