GitHub Advisoryadvisory · Packagist

GHSA-4hjf-6pxr-549h Moodle Cross-site Scripting vulnerability

LOW Published 2024-11-11 Modified 2024-11-12 Official page ↗
Aliases
CVE-2024-43437
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-11-12

Affected packages

• Packagist moodle/moodle: >= 4.4.0, < 4.4.2 → fixed in 4.4.2 • Packagist moodle/moodle: >= 4.3.0, < 4.3.6 → fixed in 4.3.6 • Packagist moodle/moodle: >= 4.2.0, < 4.2.9 → fixed in 4.2.9 • Packagist moodle/moodle: < 4.1.12 → fixed in 4.1.12

Description

A flaw was found in moodle. Insufficient sanitizing of data when performing a restore could result in a cross-site scripting (XSS) risk from malicious backup files.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References