GitHub Advisoryadvisory · PyPI

GHSA-4hm6-w6qq-w73v LangGraph JavaScript custom authentication may permit cross-user Store access

HIGH Published 2026-10-28 Modified 2026-10-28 Official page ↗
Aliases
CVE-2026-118668
Ecosystem
PyPI
Packages
langgraph-api
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-639, CWE-863
Reviewed
2026-10-28

Affected packages

• PyPI langgraph-api: >= 0.1.2, < 0.15.0 → fixed in 0.15.0

Description

Summary LangGraph deployments using JavaScript or TypeScript custom authentication may fail to apply Store authorization changes returned by an authorization handler. In affected deployments, an authenticated user may be able to access Store data outside their authorized namespace. Required conditions A deployment is affected only when all of the following conditions apply: • It uses an affected `langgraph-api` version. • It runs JavaScript or TypeScript custom authentication. • Its Store authorization handler relies on rewriting the requested namespace to restrict each user to their own data. • The attacker can authenticate as an ordinary user. • Multiple users' data is stored through the affected authorization path. Python custom authentication handlers are not affected. JavaScript or TypeScript handlers that reject unauthorized namespace requests instead of rewriting them are also not affected. The attack does not require administrator privileges, user interaction, a race condition, or the bypass of another mitigation. Impact An authenticated user may be able to read, overwrite, search, or delete Store data belonging to another user. Patches The issue is fixed in `langgraph-api` version `0.15.0`. The server now carries changes made by a JavaScript or TypeScript authorization handler across the runtime boundary and applies them before performing the Store operation. It validates the resulting namespace after authorization and rejects the request if an authorization change is malformed or cannot be applied safely. Users should upgrade to `langgraph-api>=0.15.0`. Workarounds Deployments that cannot upgrade immediately should change JavaScript or TypeScript Store authorization handlers to reject requests for unauthorized namespaces rather than relying on namespace rewriting. This workaround must be applied to every Store action exposed by the deployment.

Related

Alias · CVE (1)

  • CVE-2026-118668 langgraph-api implements the LangGraph API for rapid development and testing. vulnerability

Weakness · CWE (2)

  • CWE-639 Authorization Bypass Through User-Controlled Key weakness
  • CWE-863 Incorrect Authorization weakness

References