GitHub Advisoryadvisory · PyPI

GHSA-4jcj-7x88-m979 LiteLLM: MCP Proxy Has Improper Authentication

MEDIUM Published 2026-06-21 Modified 2026-09-10 Official page ↗
Aliases
CVE-2026-12773
Ecosystem
PyPI
Packages
litellm
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-287, CWE-303
Reviewed
2026-09-10

Affected packages

• PyPI litellm: < 1.84.0 → fixed in 1.84.0

Description

A weakness has been identified in BerriAI litellm up to 1.59.8. Affected is the function UserAPIKeyAuth of the file litellm/proxy/_experimental/mcp_server/auth/user_api_key_auth_mcp.py of the component MCP Proxy. Executing a manipulation can lead to improper authentication. The attack may be launched remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure.

Related

Alias · CVE (1)

  • CVE-2026-12773 A weakness has been identified in BerriAI litellm up to 1.59.8. vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-303 Incorrect Implementation of Authentication Algorithm weakness

References