GitHub Advisoryadvisory · Packagist

GHSA-4jm2-c9jr-6prf Moodle allows attackers to bypass a messaging-disabled setting

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-0214
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.7 → fixed in 2.6.7 • Packagist moodle/moodle: >= 2.7.0, < 2.7.4 → fixed in 2.7.4 • Packagist moodle/moodle: >= 2.8.0, < 2.8.2 → fixed in 2.8.2

Description

message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.

Related

Alias · CVE (1)

  • CVE-2015-0214 message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated… vulnerability

References